theMGZS.co.uk   Navigation

ArcadeModifications AboutNews Flyers Forum Events Home

Home
Go Back   theMGZS.co.uk :: MG ZS forum > theMGZS.co.uk > General Discussion

Reply
 
Thread Tools Display Modes
Old 26-03-20, 08:05 PM   #1
rover_ed
Member
 
Join Date: May 2014
Posts: 304
rover_ed is on a distinguished road
Asking help about another car

Is it ok if i can ask some advice about my other car a 620ti
rover_ed is offline   Reply With Quote
Old 26-03-20, 09:03 PM   #2
stamford
Site Owner
 
stamford's Avatar
 
Join Date: Jul 2007
Location: Waterlooville, Hants
Posts: 23,878
stamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud ofstamford has much to be proud of
Of course. Someone may be able to help.
__________________
------------------------------
theMGZS.co.uk Admin
------------------------------
__________________
Some useful links:
stamford is offline   Reply With Quote
Old 26-03-20, 09:54 PM   #3
rover_ed
Member
 
Join Date: May 2014
Posts: 304
rover_ed is on a distinguished road
Thanks. Well its a rover 620ti having problems with coolant fans not kicking in unless the sensor is unplugged ive tried 3 sensors still no luck i asked about the relay but was told if they come in when sensor unplugged the relays are working im out of ideas now
rover_ed is offline   Reply With Quote
Old 27-03-20, 09:36 AM   #4
peterzs
promoted bloke!
 
peterzs's Avatar
 
Join Date: May 2008
Location: bournemouth
Posts: 16,458
peterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to beholdpeterzs is a splendid one to behold
Found this.

https://www.mg-rover.org/threads/199...n-town.428888/

hope it helps
__________________
------------------------------
theMGZS.co.uk Admin
------------------------------
__________________
peterzs is offline   Reply With Quote
Old 28-03-20, 09:22 PM   #5
talkingcars
Site Supporter
 
Join Date: Feb 2008
Location: UK
Posts: 10,412
talkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to behold
If the ECU starts the fans when the sensor is unplugged the ECU and the fans are ok, and so is the wiring to the sensor so I would change the sensor, about 10 from DMGRS.
__________________
------------------------------
theMGZS.co.uk Supporter
------------------------------
__________________
talkingcars is offline   Reply With Quote
Old 28-03-20, 10:17 PM   #6
rover_ed
Member
 
Join Date: May 2014
Posts: 304
rover_ed is on a distinguished road
This is my third new sensor all genuine ones aswell but someone's told me they had 6 only 2 of them worked
rover_ed is offline   Reply With Quote
Old 29-03-20, 12:02 PM   #7
Gott
Member
 
Join Date: Sep 2014
Location: Boston, Lincolnshire
Posts: 88
Gott is on a distinguished road
I had this issue on my ZR last month after years of having to run without the sensor plugged in.
Despite fitting a new sensor I had the same issue; had the car in at the garage and they reset the sensor. Good as gold.
__________________
[SIGNATURE INTENSIFIES]
Gott is offline   Reply With Quote
Old 29-03-20, 12:16 PM   #8
talkingcars
Site Supporter
 
Join Date: Feb 2008
Location: UK
Posts: 10,412
talkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to beholdtalkingcars is a splendid one to behold
Quote:
Originally Posted by Gott View Post
.had the car in at the garage and they reset the sensor. ...
I didn't know you could do that.
__________________
------------------------------
theMGZS.co.uk Supporter
------------------------------
__________________
talkingcars is offline   Reply With Quote
Old 04-04-20, 10:19 PM   #9
rover_ed
Member
 
Join Date: May 2014
Posts: 304
rover_ed is on a distinguished road
Didnt no you could reset sensor.
rover_ed is offline   Reply With Quote
Old 29-04-20, 08:25 PM   #10
rover_ed
Member
 
Join Date: May 2014
Posts: 304
rover_ed is on a distinguished road
Back again i had my ecu tested at best of british and was told its fine fitted another sensor from a friends car still no joy on the fans coming on
rover_ed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:05 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright ? 2010 theMGZS.co.uk